iOS beta 버전 사용 시, Xcode 지원 문제 해결하기

iOS beta 버전을 설치한 기기와 Xcode 정규 버전을 사용할 시, 아래와 같이 DeviceSupport 부분에서 문제가 발생합니다. 이를 해결하기 위해선 Beta 버전의 Xcode를 설치하거나, iOS beta 버전을 정규 버전으로 돌려주셔야 합니다. 아래 설명에서는 Xcode 기기 지원 부분을 iOS Beta 부분에 맞추는 방법임으로 참조하시기 바랍니다.


iOS beta 버전 사용 시, Xcode 지원 문제 해결하기

1) 현재 포스트 작성 당시의 iOS 버전은 11.3 Beta 4 이며, Xcode 9.2 (정규)를 사용하고 있습니다. 후에 어떤 Beta 버전이 나오던 방법은 아래와 같이 진행하시면 됩니다. 먼저, Xcode 9.3 beta 4(현재 기준)을 다운 받습니다.

2) Xcode-beta.app을 그대로 사용하면 iOS Beta 버전을 지원하지만, 용량이 만만치 않기 때문에 두개를 아래와 같이 동시에 사용하는 것은 공간 활용 측면에서 비효율적입니다. 이 문제를 해결하기 위해 beta.app의 DeviceSupport 부분에 있는 iOS 11.3만 빼서 Xcode로 옮기도록 하겠습니다.

3) Xcode-beta.app이 /Applications에 있다고 가정할 때, 아래 경로로 이동합니다. 그리고, 11.3 (15E5201e)를 복사합니다.

/Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

4) 복사한 폴더를 아래 경로에 복사합니다.

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

5) 이제 다시 Xcode.app을 실행해보면, 경고창이 사라지며, 올바르게 연결된 것을 알 수 있습니다. 올바르게 작동하는 것을 확인하셨으면 Xcode-beta.app을 삭제하시면 됩니다.


참조

댓글 남기기